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1. The First Experiment

This chapter will guide you briefly through the main features of the Patch-
master program and should take you a maximum of about 2 hours to read
it. It briefly describes how a very simple first experiment with Patchmas-
ter could look like. Of course, you will not have to do a real experiment,
instead you should use the model circuit to simulate the conditions of a
patch-clamp recording. The reader should not worry about options that
are unclear, because more detailed descriptions of all of the mentioned steps
are to follow. This section is designed for users that can’t wait to get some-
thing done with Patchmaster. The basic requirements for starting the
program and for performing a simple experiment are outlined. For more
detailed descriptions of the features, refer to the Patchmaster reference
manual.

Note: In the following it is assumed that the hard- and software
have already been set up correctly. Please refer to the chapter
”Software Installation” in the Patchmaster reference manual
for the installation of Patchmaster. If you plan to use the
EPC 10 Double or Triple you should also first read the chap-
ter ”Setting up the EPC 10” in the Patchmaster reference
manual to get an idea of the basic amplifier operation.

1.1 Starting PATCHMASTER

Turn on the interface and the computer and start Patchmaster either via
Programs/Heka/Patchmaster (Windows) or by clicking on the icon Patch-
master (Mac). While starting the program, these things can happen:

� You may not have the hardware key correctly installed. Patchmas-
ter will continue to run in Demo mode, with a stimulus simulation
of the AD board. For installation of the hardware key, please refer to



2 The First Experiment

the Installation Guide. Note that in the Demo mode it is not possible
to save files!

� You may not have connected any AD/DA hardware. Patchmaster
will recognize this and will ask you to abort, to continue, or to try
again. If you just forgot to turn on the power of the EPC 10 or the
ITC-16, do so and select Retry. If you don’t have either of them, you
still can select Continue, i.e., Patchmaster will continue to run.
Data acquisition will be disabled but opening, saving and printing
files will be possible.

� You may not yet have a so-called ”Configuration File” (i.e., a file
with the extension ”.set” that contains all of your individual pro-
gram settings). Patchmaster will then come up with ”Cannot find
configuration file: use defaults or find file”. If you do not have a
configuration file, select Use Defaults. In this case, Patchmaster
will generate default settings and will come up with a selection of
windows.

Based on your configuration file, Patchmaster will now look for file paths
and a default Pulse Generator File (PGF) that contains your stimulus
protocols. The factory default is the file DefPGF v9.pgf in the Data folder
inside the HEKA folder.

If Patchmaster cannot find your .pgf file, it will write a message into the
Notebook window and will create a default file with only one entry called
Test. There may be other paths missing and Patchmaster will put up
an alert to that effect. You can safely ignore that error message, we will
setup these paths next in the Configuration window (see below).

After loading its configuration and pulse generator file, Patchmaster will
ask for your amplifier or AD/DA board. Please choose your connected
device.

http://www.heka.com



1.1 Starting PATCHMASTER 3

Note: In case Patchmaster does not find the ”Scale file”
that includes the calibration of your amplifier, you will be asked
to enter the correct path.

Then Patchmaster will ask whether you wish to create a new experiment
or just want to analyze some data:

There are four possibilities:

� Modify opens an existing experiment for modification, i.e. you can
delete or add further experimental data to a file.

http://www.heka.com



4 The First Experiment

� Read opens and displays an existing experiment. The file will be
write protected, so that modification (or loss) of data is prevented.

� Quit cancels the dialog.

� Create allows you to create a new experiment file.

Select the Create option to start with a new experiment. You can call the
file whatever you like, e.g. Tutorial.dat.

Note: A Patchmaster experiment consists of at least 3 files,
the raw data (file name extension: *.dat), the pulse protocols
used (*.pgf) and a file that contains the amplifier settings and
structure of your experiment (*.pul). You don’t have to cre-
ate all files by yourself and you can also ignore the file exten-
sions. If you create a new experiment, simply type the name
of the experiment, e.g. ”Tutorial”. For more information, see
Patchmaster reference manual, Appendix: File Overview.

1.2 Configuring the Hardware

Patchmaster will open some windows: the most obvious one is the
Oscilloscope window. We will deal with that window soon; however,
first we have to make sure that the hardware is connected properly and
that the software settings meet the requirements. The most important
hardware settings are defined in the Configuration window.

To open it, select Configuration from the drop-down menu Windows.

http://www.heka.com



1.2 Configuring the Hardware 5

1.2.1 Files and Paths

The Configuration window provides a variety of parameters that can be
adjusted. First of all, in order to tell Patchmaster where to look for the
relevant files and where to store your data, you need to set up the paths
and files. Usually, if you install Patchmaster with its default settings,
you can leave these entries untouched.

In case you install into other directories, though, please adapt the paths,
e.g., Home Path, Data File, Protocol File, PGF Pool File etc., in the Files
and Paths section of the Configuration window according to your local

http://www.heka.com



6 The First Experiment

installation settings.

For more information on the contents of the various files, see the Patch-
master manual, Appendix: File Overview.

1.2.2 AD/DA Channels

Patchmaster has to know whether to
use an EPC 10 patch-clamp amplifier
or another amplifier: use the control in
the top left of the screen.

� If your particular amplifier is not in the list, select the EPC 7.

� If you have no amplifier at all, use the Demo mode instead.

� If your amplifier is not an EPC 10 (nor EPC 10/2 or EPC 10/3)
you will also have to define the AD/DA converter you use (ITC-16,
ITC-18, or LIH 1600) in the lower popup control (3). In this exam-
ple, you cannot select an AD/DA-board (the selections are disabled),
since the EPC 10 uses its built-in AD/DA converter. In case you are
running Patchmaster with multiple PCI boards, the active one has
to be specified as well.

The next step will be to define the AD and DA channels to be used for
stimulation and acquisition of data in the sections DA channels and AD
channels. For users of the EPC 10, some of these channels are predefined:

� the voltage stimulus is always expected to go via Stim-DA (V-
membrane Out).

� the current input is sampled via Imon2 (Current In) and

� the voltage is sampled from Vmon (Voltage In).

http://www.heka.com



1.2 Configuring the Hardware 7

Note: The EPC 10 has 4 DA output channels (0. . . 3) and 8
AD input channels (0. . . 7). For the EPC 10 Single, the chan-
nels DA 0..2 and AD 0..4 are available.
For the EPC 10 Double, the channels DA 0..1 and AD 0..2 are
available.
For the EPC 10 Triple, the channels DA-0 and AD-0 are avail-
able. The other channels are internally hardwired to the current
and voltage output of the respective amplifiers.

1.2.3 Using the Software without Connected AD/DA
Hardware

In general you have two possibilities for using the software without con-
nected amplifier hardware: the Demo mode and the Stand-alone mode.

1.2.3.1 Demo mode

When no dongle is connected to the computer, the software will start in
the true Demo mode. In this case, you will see the following warning:

The Demo mode can be used to inspect and analyze data on an extra
computer that is not connected to the setup and to evaluate the software
package. In this mode, no data can be stored to disk, but replay and export
functions are working.

Note that any output that is created is taken as input; i.e., if a Stim.Scaling

http://www.heka.com



8 The First Experiment

of 0.1 is selected, the system now behaves as if an amplifier is connected
with a pipette having a resistance of 10 MΩ.

1.2.3.2 Stand-alone mode

When a dongle is connected to the computer, the software will start in the
Stand-alone mode. In this case Patchmaster will come up with the mes-
sage ”AD/DA initialization failed: check power!” or ”EPC 10 initialization
failed! Please, check power and connections”.

The Stand-alone mode can be used to inspect and analyze data on an extra
computer that is not connected to the setup. In this mode, data can be
edited and saved to disk.

Note that any output that is created is taken as input; i.e., if a Stim.Scaling
of 0.1 is selected, the system now behaves as if an amplifier is connected
with a pipette having a resistance of 10 MΩ.

1.2.4 Entering the Parameters

So far, we specified the most important settings. On the left-hand side
of the Configuration window - the Parameters section - there is a list of
further values that are acquired and stored together with the experiment.
These parameters can be input via different means:

� they can either be sampled through a free AD channel (Source =
AD-0 ... AD-4)

� they can be derived directly from the Amplifier (Source = EPC) like
the settings of the C-slow compensation (C-slow and G-series) or

� they can be typed in by the user during the running experiment
(Source = Default).

The checkboxes in the parameter list left to each parameter determine
whether the parameter is displayed in the I/O-Control window.

http://www.heka.com



1.2 Configuring the Hardware 9

Note: The checkboxes to the left of each parameter only define
if the corresponding setting will be visible within the Patchmas-
ter session. Irregardless of this setting, Patchmaster will al-
ways store every parameter with every block of data acquired. A
separate block of data is called a ”sweep” in the Patchmaster
terminology.

Go through all of these
parameters, select the in-
put source and maybe new
default values. If an AD
channel is used as an in-
put source, then the scal-
ing can be specified. Let
us suppose the tempera-
ture is read from a tem-
perature control unit via
AD channel 4. Let’s further assume that the control unit delivers an ana-
log signal of 100 mV/˚C and 0 V at 0 ˚C. Then the scaling factor to be
entered is 10 (1 V corresponds to 10 ˚C) and the offset is 0. Click the scale
button next to the Temperature Parameter and fill in these settings.

If you are sampling from a so-called ”telegraphing” amplifier, the determi-
nation of the encoded amplifier gain and filter bandwidth settings is much
more involved and is done via lookup tables that are provided as ASCII
files. You can select the corresponding gain or bandwidth table with the
button table.

1.2.5 Saving the Configuration

Finally, you can save the configuration:

� click SAVE if you want to save the file under the default name Patch-
master.set or

� click SAVE AS if you want to save the file under another name. This
is simply for your personal use, since Patchmaster will always start
with the default file Patchmaster.set.

http://www.heka.com



10 The First Experiment

1.3 Controlling the Amplifier

The EPC 10 Amplifier window provides the amplifier control functions
when an EPC 10 amplifier is used (the picture is for an EPC 10 Single).
More detailed descriptions of the functions of the EPC 10 versions and
their control windows are given in the corresponding amplifier manuals.

If you have an amplifier other than the EPC 10, you have to make sure
that:

� the command potential at the amplifier is set to zero,

� the stimulus scaling is set correctly,

� the DA channel for Stimulus Out is connected to the amplifier’s stim-
ulus input,

� the amplifier’s current monitor is connected to the Current In AD
channel,

� if the amplifier has telegraphing capabilities for gain and/or band-
width, ensure that the corresponding analog outputs are connected
to the assigned AD channels. Gain and bandwidth lookup tables in
ASCII format, which translate the voltage output to the setting of
the corresponding switch, can be used for telegraphing amplifiers (see
Chapter ”Configuration” in the Patchmaster reference manual).

1.3.1 The Default Macros for Cell Set-Up

In the first row of the EPC 10 Amplifier window, you can find three con-
trols. These are predefined macros.

SET-UP: Resets all parameters (with the exception of LJ and V0), and
defines the parameters of the test pulse.

ON-CELL: Switches the Gain range to a typical setting for a cell-attached
patch recording, sets initial C-fast estimates, and invokes an Auto C-fast
compensation.

http://www.heka.com



1.3 Controlling the Amplifier 11

Figure 1.1: The Amplifier Window

http://www.heka.com



12 The First Experiment

WHOLE-CELL: Switches the Gain range to a typical setting for a whole-
cell recording, sets initial C-slow estimates, and invokes an Auto C-slow
compensation.

These macros can be redefined and other macros can be recorded using the
macro record function, which you can find in the Macros menu. Since the
Protocol Editor (see Chapter 1.8.1, on page 41) allows for more complex
automation, we will not discuss macros further in this manual.

1.3.2 Test Pulse

The Test Pulse is applied to the pipette whenever you activate the amplifier
by bringing the Amplifier window to the front. Test pulses are added to
the holding potential and applied to the pipette; the current responses are
sampled and displayed. Test pulses are applied at maximal rates depending
on the pulse length specified.

The Test Pulse is defined in two different windows:

� in the Amplifier window you set the Test Pulse Sequence that
shall be used and all other parameters for the Test Pulse, like ampli-
tude, duration and pulse type. Current means that the current trace
is displayed in the Oscilloscope every time the test pulse runs, while
Both displays both the current and the voltage trace. Use this if you
frequently want to apply test pulses in the Current Clamp configu-
ration.

� in the Configuration window you can set whether the Test Pulse
shall be scaled.

1.4 Setting up a Simple Pulse Protocol

The Patchmaster software allows you to stimulate with protocols that
range from simple rectangular pulses to highly complicated stimulation

http://www.heka.com



1.4 Setting up a Simple Pulse Protocol 13

patterns. Stimulus templates are edited in the Pulse Generator window.

To open it, select Pulse Generator from the Windows drop-down menu.

A pulse pattern (called ”Stimulation”) consists of an arbitrary number of
pulse Segments that have a constant, ramp, or sinusoidal voltage. In the
default Pulse Generator File, only one sequence is created. The file
DefPGF v9.pgf, distributed with the software release, is usually installed
into the Data folder inside the HEKA folder and contains several useful
pulse protocols which are a good starting point to create your own ones.

http://www.heka.com



14 The First Experiment

1.4.1 Creating a New Sequence

Click a free position in the PGF pool. If there is no free position, click the
right arrow unless you reach the end of the pool. Patchmaster will ask
you for a new Entry Name: type ”IversusV”.

1.4.2 Setting up the Timing

We want to create a protocol that gives us a current-voltage relationship.
The response to 9 depolarizing pulses in steps of 10 mV given at an interval
of 1 s has to be studied.

In the Timing section set No of Sweeps to9and the Sweep Interval to 1.
Choose the sampling interval: here 50 µs.

To edit the fields, double-click the corresponding field. Then you can enter
the number.

Usually Patchmaster will wait the time defined in Sweep Interval before
starting the pulse sequence. However, right now we want the sequence
to start immediately after activating it, so please select No wait before 1.
Sweep from the popup next to Timing.

1.4.3 Defining the Segments

The section Segments of the Pulse Generator defines the actual pulse
protocol to be applied. It will consist of three parts: the cell will be held at
the actual holding potential in the beginning and the end of the protocol,
the middle part has the depolarizing step. The individual parts of the pulse
protocol are called Segments.

At the beginning, the protocol has only one segment of 10 ms duration. To
add the additional two segments, mark the Store option for the second and
the third segment. The result should look like the following:

http://www.heka.com



1.4 Setting up a Simple Pulse Protocol 15

Although you can edit the segments in any order, it is often advisable to
start by defining the length of the individual segments. Since we want to
give all three segments the same length, we can use the PGF parameter
function.

At the bottom of the window you will find this row:

p1 to p10 are called PGF parameters. You can use them as variables in
the segment settings for Voltage or Duration. This allows you to change
multiple settings with changing only one parameter. Proceed as follows:

1. Select p2 instead of val from the drop-down menu right before the
Duration value in the first segment.

2. Click on the number under the p2 entry and enter ”0.1”.

3. Now you can see that the value in the Segments section has changed.

4. Choose p2 for the other two segments too. All segments are set to
”p2=100” [ms] now.

The first and last segment should be at holding potential, so select hold
instead of val from the drop-down menu right before the Voltage value.
The value in Voltage [mV] changes to V-membr. (i.e. the actual pipette
holding potential at the time of executing the protocol).

http://www.heka.com



16 The First Experiment

Change the value in the second segment to p1 and set the PGF parameter
p1 to −− 60.

Then set the Delta V-incr. [mV] field to 10. This will instruct Patch-
master to jump to -60 mV when it first executes the protocol and then
always increment this segment by 10 mV for the following 8 repeats (-50,
-40, -30, ..., +20 mV). The segments and their preview should look like the
following:

If a segment is set to V-membr., Patchmaster will fill in the actual hold-
ing voltage at time of data acquisition. In the sequence cartoon of the
Pulse Generator the segments are filled in with the value entered under
V-membrane [mV] (display). Thus, to make the cartoon look realistic, you
may want to enter a typical holding voltage (e.g. to -80 mV) into the field.

Note: This value does not affect your measurement – it is only
used for previewing the sweep!

1.4.4 Defining the Segment for Online Analysis

Maybe you wondered why one segment is drawn in red color in the pre-
view while the rest is black. Patchmaster can perform an Online

http://www.heka.com



1.4 Setting up a Simple Pulse Protocol 17

Analysis whenever you run or replay an experiment (see below). This
is done by analyzing one segment (Rel Y Seg), e.g. determining its peak or
mean current, and plotting it against another parameter like the duration
or potential of any other (or the same) segment (Rel X Seg). You can
define which segment has to be analyzed by setting the so-called Relevant
Segment. This is done separately for the segment that delivers the x- and
the y-value. Set both values to ”2”.

Your later analysis will of course not be restricted to the segments you
define here. In the Analysis Functions section of the Online Analysis
window you can set a positive or negative Segment Offset that will be
added to the relevant segment, thus allowing you to analyze other segments.
For more information, see Chapter 1.7.3, on page 37.

1.4.5 Setting the Output Channel and the AD Input

In the rows Ch-1... you set the parameters for each channel. The default
channel is 1, the other channels (Channels = 2. . . ) may be used to simul-
taneously record other data such as the potential, an amperometric signal,
or a fluorescence.

DA and AD settings are independent from each other. Their reference is
only given by the variable Link in the AD settings! So to prevent confusion
here, we will split the above picture for a closer look.

The DA section on the left allows you to set the properties of the DA

http://www.heka.com



18 The First Experiment

output, e.g., the stimulus signal. Note that the expression ”channel” is
used exclusively for the DA stimulus output! The output via Stim-DA
and the Unit V are the default entries for EPC 10.

The AD section on the right allows you to set the properties of the AD
input, e.g., the acquired data. The input via Imon2 and the Y-unit A are
the default entries for EPC 10. The variable Link defines with which DA
stimulation this AD input is associated, in our case to channel 1.

Remember that this Link variable allows you to associate several AD inputs
to the same DA stimulation! The rationale behind the Link variable is that
during analysis one has to know which stimulus was applied for a given data
trace.

The option Store will make sure that the acquired data can be stored to
disk. For some protocols it might not be required to save the data (such as
a Test Series), so you can disable this feature in these cases.

1.4.6 Other Settings in the Pulse Generator

There are a few more options in the right and bottom part of the Pulse
Generator window that did not have to be changed in our case. Neverthe-
less, it is still important to know what they do: the setting Voltage Clamp
will restrict the execution of the pulse protocol to the voltage-clamp modes
only. Thus, Patchmaster will refuse to start this sequence if you are in
the current-clamp mode and instead will produce an error message.

Note: A given pulse protocol only makes sense for Voltage-
or Current-Clamp conditions, never for both modes. The op-
tion Any Mode in the Pulse Generator window is only there
for special applications like Photometry. If you want to be able
to run a Current-Clamp sequence while you are in a Voltage-
Clamp mode, you should create a macro or a protocol that
switches to the CC mode, and associate it with the pulse proto-

http://www.heka.com



1.4 Setting up a Simple Pulse Protocol 19

col.

The section Sweep/Channel Length gives you some important information
about the pulse protocol.

Sweep Length: Maximal possible length of a sweep, determined by the
timing settings.

� Total: Denotes the total time needed for one sweep of the given
sequence in ms and points.

� Stored: Denotes the total time stored for one sweep of the given
sequence in ms and bytes. Total and Stored durations may be differ-
ent when a Start Seg. and Start Time were set or when conditioning
segments were used (e.g. segments with the Store button off).

Channel Length: Length of the actual DA stimulation. This can be
shorter than the sweep length, e.g., a short trigger pulse.

Stimulus: Denotes the time for the stimulus signal in ms and points.

For our example, the value Total as the total length of stimulation calculates
like this: Each sweep has a duration of 100 + 100 + 100 = 300 ms sampled
at an interval of 50 µs or a frequency of 20 kHz. This makes a total number
of 6000data points.

If, for example, there was a StartSegment 1 and a StartTime 5 ms, the first
5 ms (or 100 data points) would not be saved. But since we want to store
the whole sweep to disk, we did not specify a StartSegment.

Note: Patchmaster allows you per default a maximum of 5
channels with 16382 points each. These parameters can be ad-
justed in the Configuration window, provided your computer
has enough RAM.

This new, modified Pulse Generator File should now be stored to disk
by clicking on SAVE and entering a name. The default file extension is

http://www.heka.com



20 The First Experiment

”.pgf”. Note that on program start Patchmaster will always load the file
defined in the Configuration window; the default is DefPGF v9.pgf. If
another PGF file should be loaded into the Pulse Generator as a default,
the new name of the PGF file has to be specified in the Configuration
window and the configuration file has to be saved.

The resulting Pulse Generator window should look like this:

http://www.heka.com



1.5 Starting the Experiment 21

Figure 1.2: The Amplifier Window
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22 The First Experiment

1.5 Starting the Experiment

1.5.1 Making a Seal

Now it is time for the experiment. Switch the model circuit into the
”10 MOhm” setting to simulate a 10-MΩ pipette that is open to the bath
solution.

Hit the space bar in the main dialog to activate the Amplifier window -
if the Oscilloscope is not in front, hit the space bar twice, the space bar
toggles between the Oscilloscope and the Amplifier window.

As long as the Amplifier window is on top, the program will generate
test pulses according to the settings in the Test Pulse section: a double
pulse of 5 mV amplitude and a duration of 5 ms per pulse will be output.
The sampled current responses will be shown in the Oscilloscope window.
The resistance of the pipette is calculated from the responses and displayed
in R-memb.

Besides the fast test pulses (single or double) you can select the third entry
in the Test Pulse pop-up list, which requires to specify a sequence from
the Pulse Generator File. Instead of the fast test pulses, this sequence
is then repeated continuously providing an alternative and quite flexible
Test Pulse mode.

Note: The currently measured resistance of the pipette is al-
ways called Rmemb because the program cannot distinguish be-
tween an open and a sealed pipette. As long as the pipette is
open to the bath, R-memb corresponds to the pipette resistance.

The command potential is controlled by the program via the control V-
membrane. This variable always displays the physiological membrane po-
tential, i.e., the Recording Mode is already taken into account reverting
the polarity of the applied potential in On Cell and Inside Out modes.

Note: Most functions, such as canceling the offset current,
setting the amplifier gain or the holding potential, etc. should
be obvious, but make sure that the Recording Mode is always set
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1.5 Starting the Experiment 23

properly, because this setting will automatically determine the
actual polarity of the voltage at the patch pipette!

You can correct pipette offset potentials by adjusting the Vo value or you
can alternatively click on the Auto Vo button to let Patchmaster do this
correction automatically for you. The same is done by calling the macro
SET-UP, in this case, Patchmaster will also adjust the amplifier gain
and the test pulse. When the pipette potential is adjusted and you are
ready to form a seal, store the value of the Pipette Resistance - which is
the actual R-memb value that will be overwritten after forming the seal.
This is done by clicking on R.memb → R-pip. This value is not changed
any further, unless you click on R.memb → R-pip again.

Note: R-memb is updated as long as the test pulses are active,
i.e. every time the Amplifier window is in front, and stored as
variable Seal Resistance with every acquired sweep. The Pipette
Resistance will be stored together with every acquired series of
sweeps. This value is updated every time you click on R.memb
→ R-pip.

Now simulate a pipette sealed to the membrane by switching the model cir-
cuit into the middle position. If you have an EPC 10, make an automatic
fast capacitance cancellation by clicking on the Auto C-fast or ON-CELL
macro button. Otherwise, compensate your amplifier for the pipette ca-
pacitance of about 6 pF.

To break into the cell, set the switch of the model circuit to its bottom or
”0.5 GOhm” position. If you have an EPC 10 make an automatic slow ca-
pacitance cancellation by clicking on the Auto C-slow or WHOLE-CELL macro
button. Otherwise, compensate your amplifier for the cell capacitance of
about 20 pF. Watch the R-memb display that now shows 500 M instead of
10 M. With the V-membrane control change the pipette holding potential
to -100 mV. Now we are ready to run the pulse protocol we defined before.

1.5.2 Setting up the Display

Bring the Oscilloscope window to the front. If the button Store is not
highlighted, click on it to make it active; otherwise, Patchmaster will
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show the data but not write them to disk! If you did not create a file yet,
Patchmaster will ask you to do this now.

The bottom of the Oscilloscope window shows the buttons used to control
the execution of sequences or protocols.

To see all sweeps from one series, activate the Overlay Sweep button in the
Oscilloscope window; otherwise, the display will be erased before every
sweep.

Before we execute the IversusV sequence (or ”series” in Patchmaster
terminology, which describes a number of individual sweeps based on the
same Pulse Generator Protocol) we will set up the display. Usually you
can use the default settings of a new Patchmaster installation, but let us
have a look at the Display menu. The following options should be activated:
Show Zero Line, Show Potential, Dimmed Overlay, Labeling → Grid and
Labels.
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1.5.3 Starting the Sequence from the Protocol Editor
Window

Now open the Protocol Editor window. In the top right sequence pool
you can see all available sequences/pulse patterns. (For now, we are ig-
noring all other possibilities of this window, but we will return to it in the
Chapter 1.8, on page 41.)

To start data acquisition directly, click on the IversusV button or type
”10” into the blue entry field, if IversusV is the sequence in the tenth
position.

1.5.4 Displaying the Data

The pulse pattern we defined above is output via the specified DA channel
and the response is shown in the Oscilloscope window. The last sweep
of the series is shown in black color, the other sweeps are gray since we
activated Dimmed Overlay. The grid is drawn in green color and scaling
values are given in the lower left side of the Oscilloscope.
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1.5.5 Changing the Display Settings

In case you want to have a closer look at your displayed data, you have
various possibilities to change the display settings.

For example, you can do a quick checkup on the measured values. When
you click on the button Measure, a cursor with two connected lines will
be displayed in the Oscilloscope window. The data of the actual point
will be displayed, and you can copy them into the Notebook via the To
Notebook option.
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In case the data is too small on your display, you can use the ”lasso-ing”
function. Start in the top left corner and press the left mouse button.
Pull the opening red square to the appropriate size and release the mouse
button.
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The marked area will be set to fill the oscilloscope screen. Note that the
scaling has to be done for each trace separately, even when you have selected
the Overlay option! So the result looks like the following:
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1.6 Handling Data

1.6.1 Saving Data

To write the recorded data to disk, select File → Update File or close the
experiment with File → Close. The latter will automatically store all files
associated with the experiment.

To create a new file for data acquisition, select File → New... . Patch-
master will close the running experiment and open a new, empty one.

Remember: Recorded data can only be saved and/or replayed if the Store
button was active during acquisition!

1.6.2 Replaying Data

If – and only then! – the Store button was active, the structure of the
stored data will be shown in the Data Tree of the Replay window. This
is also the basis for the replay of data.
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To open the Replay window select Replay.

Double-click the IversusV 1 entry to replay the just recorded sequence;
double-click a single sweep to inspect it in the Oscilloscope window.
You might use the cursor keys (`up´, `down´, `left´ and `right´) to walk
through the data tree.

If you press `Return´ or double-click on the currently active group, series,
sweep or trace, it will be displayed in the Oscilloscope. This may look
like the following example:
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While replaying the data, the Online Analysis will be calculated. For more
information on the Analysis options, see Chapter 1.7, on page 35.

The Replay menu provides functions for modification of the tree entries.
E.g., a single sweep, a series, or a whole group of series can be removed by
activating the item and then selecting Replay → Delete.

1.6.3 Exporting Data

You can export the data into various other file types via the export options
in the Replay menu. Patchmaster cannot only export to plain text files,
but also to formats for software like Igor Pro or MatLab.

For example: to export raw data to comma-separated ASCII format, you
would have to set the following options:

� Export Format to ASCII

� Export Mode to Traces
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� ASCII option to comma-separated and the linefeed type that would
fit your operating system.

Then you are asked for a file name. The pre-set data extension for the
output is .asc (as for ASCII).

The resulting file would look like this in a ASCII viewer, e.g., Notepad:

1.6.4 Exporting Parameters

For long series of data, you may want to get an overview of the settings
and parameters with which the data were acquired.

For this, open the Parameter window. Here all information concerning
replayed or actual data is displayed. Via the checkboxes (flag options) you
can select information that you want to export to the Notebook window or
to a file.
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The window is structured as follows:

� On the top right side you can find the flag management and the
export features.

� On the left and middle part of the window you can find the data tree
entries Root, Group, Series, Sweep and Traces, together with their
parameters.

� On the right, you can find information about the amplifier settings.

Select the data you want to export by checking the small checkboxes in
front of the relevant entries. Note that you have to check the main entries,
e.g., Root, Series etc., to export the other parameters of that group!

To test if you have selected all necessary parameters, click on Show Selected
Items only. This will close the Parameter window and give you only the
selected parameters in a new window.
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If you want to export the parameter names together with their correspond-
ing values, check the option Titles above the parameter values. Otherwise,
only the values will be exported. Then click on Target to Notebook to
export the parameters into the Notebook window.

For a setting like the this:

where the parameters of the series - that is the Target in the Replay window
– are exported with Header, Label, Date, Time and Comment (but no Titles
option), the result in the Notebook window may look like this:

With the Titles option, which will export also the parameter names, the
result would look like this:

When you click on Target to File, the program will ask for a file name. The
pre-set data extension for the output is .asc (as for ASCII).
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1.7 Analyzing the Results

1.7.1 Using the Online Analysis

The online analysis allows you to immediately calculate and display data
that are based on the acquired traces, thus giving you a fast overview over
your results.

The highlighted Analysis Method is the one that will automatically be
executed when you acquire or replay data.

Patchmaster can show such analysis results as columns in the Notebook
window or plot them in the Online Analysis windows 1 or 2 after or
during execution of a series (based on the settings made in the various
controls inside this window).

The Online Analysis is structured as follows:

1. Based on incoming data, a number of Analysis Functions are de-
fined.

2. These functions produce Analysis Results based on the relevant
segments of the sequence.
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3. These results are then displayed in the Notebook (if the Notebook
option is checked) and/or shown in an Online Graph inside either
Online Window 1 or Online Window 2.

Elements of a Graph are Graph Entries, i.e. couples of Analysis Results
to be used as X- and Y-reference. Up to 4 Graph Entries fit into one Graph;
multiple Graphs fit into Online Window 1 or 2.

The entire setting of the Online Analysis is called Analysis Method. An
arbitrary number of such Analysis Methods can be saved in Online Analysis
files (*.onl).

Thus, the first thing to do is to define Analysis Functions. Only then,
the respective Analysis Results are placed as Graph Entries in Graphs
and Windows.

1.7.2 Entering a New Analysis Method

Usually, you can set up a new Analysis Method by copying the data from
one method to the other. However, for the purpose of this tutorial we will
start from scratch.

Click on New and enter the name ”Integral” for the new Analysis Method.
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It will be created and placed on the next free entry number.

1.7.3 Entering the Analysis Functions

Extr-1 is given as default Analysis Function. Now we need to customize
our method. Click on Extremum to open the Function Type window.

Choose the entry Time and click Done.
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The first entry in the section Analysis Functions of the Online Analysis
window has changed to Time-1. The ”1” tells you that you analyze trace 1
here, as you can see on the right. Later we will use this result for an x-axis
variable.

Now we need some other function to provide a variable for the y-axis. We
simply want time at data acquisition there, so click on New to set up a new
function, choose Integral from the Function Type window and click Done.

Now we have two functions that analyze Trace 1. We also want both results
to be copied into the Notebook, so check the Notebook option for both.

Remember that all analyses will be performed on the relevant segment of
the sequence as it is set in the Pulse Generator window (see Chapter
1.4.4, on page 16).

Also note that the order in which the data is displayed in the Notebook
window later on depends on the order of the functions in the Analysis
Function section. This means, if you prefer a certain order, you have to
select them accordingly at the very start.

1.7.4 Setting up the Analysis Graph

To set up the graph, you first have to define in which Online Window (1
or 2) the graph shall be displayed. We want to display Graph 1 in Win 1.
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Then we have to define the Graph Entries. Up to four Graph Entries can
be in one Graph, but we need only one entry here.

To define the entry, check the first entry (light green in our example) and
then choose the x- and the y- axis.

The color of the graph field will be the display color in the future graph.
Light green is not very handy – let us change this to dark blue. For this,
click on to open the following window:

Change the color by clicking on the Color button and choosing from the
possible colors. Click Done to save your selection.
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1.7.5 Performing an Online Analysis

First, make sure that the new method ”Integral” is highlighted.

Second, open the Online Window 1 by selecting Windows → Online Win-
dow 1.

Third, acquire data or replay data by double-clicking on the series in the
Replay window. The analysis results will be displayed in the Online
Window 1 and in the Notebook window.

The result in the Online Window should look like the following:

If you bring the Notebook window to the front (e.g. by selecting Windows
→ Notebook), you should see something like this:
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In case not all data are listed here, check the Notebook checkbox for each
function!

1.8 Automating the Data Acquisition

1.8.1 Getting to Know the Protocol Editor

In a former chapter, we used the Protocol Editor window solely to start
the sequence. However, the Protocol Editor has much more possibilities
– in this window you can assemble complex experimental arrangements by
combining PGF-templates with other operations (e.g. breaks, IF-THEN
loops, setting changes). This window is the heart of the Patchmaster
software concerning the automation of experiments.
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Note that in the Protocol Editor window there are two different kinds of
pools:

The sequence pool on top right is the direct connection to the Pulse
Generator window. When you click on an entry, the respective sequence
will be started and executed as often as it is set in the No. of Sweeps
variable in the Pulse Generator window. To stop its execution, click on
Stop. Note that the buttons on the left of the sequence pool correspond to
the buttons in the Oscilloscope window.

Below the sequence pool, there is the protocol pool. Here you can find all
protocols that have been set up until now.

The protocol that we use in this tutorial looks like the following:
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As you can see, each entry – or as it is called, event – has its own index
number. You can use these numbers if you want to move an entry to
another position.

After the index number, the event name is displayed, e.g., Amplifier.
When you click on an event, the corresponding input fields will be opened
on the right.

1. In the first event – Macro Command– the command ”E Gain 11” will
be executed. This command sets the Gain value in the Amplifier
window, in our case to 10 mV/pA. Although there are some ampli-
fier settings that can be set in the Protocol Editor (see below),
others have to be set via a macro command. You can find out these
commands by recording a macro with the necessary steps and then
analyzing the macro content. For further information, please read
the Chapter Macros in the Patchmaster reference manual.

2. In the second event – Amplifier – nothing more is done than to
set the Recording Mode to Whole Cell and to mark Auto C-slow
correction.
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3. This is followed by a Wait event. This event is useful if you want to
be alerted during the protocol execution, perhaps because you want
to change some external settings before the actual data acquisition
takes place. Only when you press the key ”b”, the protocol execution
will proceed.

4. Up to now, these settings could have been set manually by the user.
However, the following event Repeat is the start of a loop, in this
case a Repeat Counts with ”4”. This way, the loop will be repeated
four times.

5. ”– inside the repeat –” is a text entered in the so-called Annotation
event. This annotation is only readable in the Protocol Editor, i.e.,
will not be displayed in the Notebook or elsewhere.

6. Series shows that the Acquire Series event is called, in this case
our PGF Sequence ”IversusV”. This starts the data acquisition. Note
that you can directly open the PGF Template from the event menu
to edit this sequence.

7. The next event is End REPEAT, which marks the end of the loop. This
event is automatically inserted when you insert a REPEAT event.

8. When the loop has finished, the Beep event is called.

To start this protocol, click on the Go button.

Since in our example the options Show and Write are activated, the re-
spective event will be highlighted in the event list and also written into the
Notebook; the latter should read like the following:
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Just as in normal data acquisitions, the data will be automatically analyzed
by the activated Analysis Method. But be aware that as long as the
protocol is executed, you cannot change entries in the Online Analysis
window. If you try it anyway, the message ”Cannot modify online: still
executing or acquiring...” will be displayed in the Notebook window.

The same holds for the Protocol Editor itself – if you click on an entry
in the event list during execution, the message ”Cannot run: protocol is
already executing...” will be displayed in the Notebook window.

In this case, you have to click Stop or Break to halt protocol execution.
Then you are able to modify parameters again.

1.8.1.1 On the Difference between Macros and Protocols

In general, automation can also be achieved with macros. The differences
between macros and protocols are:

� With macros, you can record sequences that are actually performed.
All buttons and settings in all windows can be included into a macro.
While recording the macro, though, you have to jump between the
necessary windows. This will also happen during macro execution,
thus slowing-down the process.
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� With protocols, very complex sequences can be edited. During proto-
col execution no opening or closing of windows is necessary, thus the
execution is faster than for macros. Another important advantage of
protocols over macros is the possibility of conditional events, depend-
ing on e.g., analog or digital input, analysis results or key commands.
But note: Only a limited number of settings can directly be set in
the events. For all others you have to include a macro command via
the Macro Command event.

We highly recommend the use of protocols.

1.8.2 Changing PGF Parameters via a Protocol

You also have the possibility to manipulate the PGF parameters of the
Pulse Generator window in a protocol.

Remember: We used the PGF parameters p1 and p2 in our segment defi-
nitions, see Chapter 1.4.3, on page 14.

With the event PGF Parameters you can set a value for the parameter. Do
as follows:
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1. Mark line 3 in your event list and Insert After the event PGF
Parameters. Set p2 to 20 mV.

2. Then mark the new line 7 and Insert After the event PGF Parameters
again. Here, set p2 to 50 mV.

This way, you will get a first execution of ”IversusV” with a lower p2, and
a second execution with a higher p2.

When the protocol has been executed, you can see the resulting PGF values
also in the Pulse Generator window.
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Note that when you execute a series the next time, the value 50.000m will
be used as start value for p2!

1.9 Customizing the Front-End

1.9.1 Customizing the Keys

In Patchmaster, all key commands are saved in the file PatchMaster.key
and will be read at program start. In case the file PatchMaster.key is not
available at program start, no key commands are available!

Please take also in consideration that you can customize all commands, so
the settings in your working version of Patchmaster might differ from
these default settings.

To display the key assignments in the various windows, choose Help →
Show Keys.

To list the keys, choose Help → List Keys.

To save the keys, choose Help → Save Keys. The keys are saved in the file
PatchMaster.key. Old keyboard assignments will be automatically saved
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with an incrementing extension, e.g., .k00, .k01, .k02 ...

You can freely customize the key commands by

� editing the keys via the dialog control and saving them or by

� directly modifying the key file, e.g., in a text editor.

1.9.2 Customizing the Windows

To modify dialog and control items in the Patchmaster user interface,
you have to select Enable Icon Configuration from the Windows menu and
then press certain controls, depending on your intended action and your
operating system (Windows, Mac OS). For further information, please refer
to the Chapter ”Modifying Dialogs and Controls” in the Patchmaster
reference manual.

1.10 Closing PATCHMASTER

To exit from Patchmaster, do this:

Choose Quit from the drop-down menu File or press `CTRL´ + `Q´.

Press `CMD´ + `Q´.

The following window will appear:

http://www.heka.com



50 The First Experiment

You have three possibilities:

� Save + Exit: Saves data files and configuration and quits the pro-
gram. At least the first few times of running Patchmaster, after
tuning the system, you should do that, since this file contains all of
the settings that were adjusted as outlined above. Once you have
a stable system, which you don’t want to modify anymore, you can
safely ignore this question.

� Exit: Saves data files and quits the program.

� Cancel: Aborts the exit process, you return to the program. This is
the right button if you accidentally pressed the shortcut combination
for exiting.

As you can see, data files will always be saved. If you lose data files, you
might verify if you checked the option Store in the PGF editor or the option
Store in the Oscilloscope window during your experiment.

If you changed the pools in the Protocol Editor or the Pulse Generator,
you will be asked independently if you want to save them.

The default is Save for each, so just press `Return´ twice to save them and
exit the program.
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